summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorzlg <zlg@zlg.space>2018-09-03 02:52:57 -0700
committerzlg <zlg@zlg.space>2018-09-03 02:55:21 -0700
commit565812a92cd22d41aa6f5f85a6b451386422fb4a (patch)
tree5858923eb443465c078040c0e8cc13739290f195 /setup.py
parentFlesh out filter types and ownership status (diff)
downloadvgstash-565812a92cd22d41aa6f5f85a6b451386422fb4a.tar.gz
vgstash-565812a92cd22d41aa6f5f85a6b451386422fb4a.tar.bz2
vgstash-565812a92cd22d41aa6f5f85a6b451386422fb4a.tar.xz
vgstash-565812a92cd22d41aa6f5f85a6b451386422fb4a.zip
Branch off from master with pytest, tox, click
This commit is huge, but contains everything needed for a "proper" build system built on pytest + tox and a CLI built with click. For now, this branch will contain all new vgstash development activity until it reaches feature parity with master. The CLI is installed to pip's PATH. Only the 'init', 'add', and 'list' commands work, with only two filters. This is pre-alpha software, and is therefore not stable yet.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..82fd062
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,46 @@
+# -*- coding: utf-8 -*-
+
+# Learn more: https://github.com/kennethreitz/setup.py
+
+from setuptools import setup, find_packages
+
+
+with open('README.md') as f:
+ readme = f.read()
+
+setup(
+ name='vgstash',
+ version='0.3-alpha3',
+ description='a video game collection management module, backed by SQLite',
+ long_description=readme,
+ long_description_content_type="text/markdown; variant=CommonMark",
+ author='zlg',
+ author_email='zlg+vgstash@zlg.space',
+ url='https://git.zlg.space/vgstash',
+ packages=find_packages(where='src'),
+ package_dir={'': 'src'},
+ py_modules=['vgstash_cli'],
+ entry_points={
+ 'console_scripts': [
+ 'vgstash=vgstash_cli:cli',
+ 'vgstash_tk=vgstash_tk:main'
+ ],
+ },
+ install_requires=[
+ 'Click>=6.0', # for better Windows console support
+ ],
+ #py_modules=["vgstash"],
+ classifiers=(
+ "Development Status :: 2 - Pre-Alpha",
+ "License :: OSI Approved :: GNU Affero General Public License v3",
+ "Operating System :: POSIX :: Linux",
+ "Programming Language :: Python :: 3 :: Only",
+ "Topic :: Games/Entertainment",
+ "Topic :: Utilities",
+ ),
+ project_urls={
+ 'Bug Reports via Web': 'https://code.foxkit.us/zlg/vgstash/issues',
+ 'Source': 'https://git.zlg.space/vgstash',
+ }
+)
+